It is currently Tue Sep 02, 2014 3:55 pm

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Broken C64
PostPosted: Wed Feb 20, 2008 10:38 pm 
Offline

Joined: Wed Feb 20, 2008 10:29 pm
Posts: 2
Hello all,

I have faulty C64 :(. When I start my Commodore I see this picture:
Image .

Can anyone suggest, what's wrong with my computer?

Thanks in advance,
Janno


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 20, 2008 11:01 pm 
Offline

Joined: Sat Oct 14, 2006 9:30 am
Posts: 140
U17 PLA is a pretty good guess:

http://personalpages.tds.net/~rcarlsen/cbm/c64-ic.txt


Top
 Profile  
 
 Post subject: Re: Broken C64
PostPosted: Wed May 13, 2009 6:16 pm 
Offline

Joined: Thu Jan 22, 2009 1:56 pm
Posts: 73
i think it looks allright :D


Top
 Profile  
 
 Post subject: Re: Broken C64
PostPosted: Thu May 14, 2009 11:36 am 
Offline
Site Admin

Joined: Wed Jan 11, 2006 12:22 pm
Posts: 845
Check if the computer responds on blind commands. Try LOAD "$",8 and see if the diskdrive starts spinning. If so it's probably a bad VIC chip. Could also be bad RAM or ROM. Touch all the chips to see if anyone is unusually hot (SID and PLA normally runs hot but you shouldn't burn your fingers)


Top
 Profile  
 
 Post subject: Re: Broken C64
PostPosted: Thu May 14, 2009 1:15 pm 
Offline

Joined: Wed Feb 20, 2008 10:29 pm
Posts: 2
RaveGuru wrote:
Check if the computer responds on blind commands. Try LOAD "$",8 and see if the diskdrive starts spinning. If so it's probably a bad VIC chip. Could also be bad RAM or ROM. Touch all the chips to see if anyone is unusually hot (SID and PLA normally runs hot but you shouldn't burn your fingers)

Thanks, I'll do that.
I replaced the U17, but problem still remained. So it has to be something else.


Top
 Profile  
 
 Post subject: Re: Broken C64
PostPosted: Thu Jul 02, 2009 6:01 pm 
Offline
User avatar

Joined: Mon Jun 15, 2009 6:55 pm
Posts: 79
U16 CD4066 (generic CMOS quad bilateral switch)
Color problems such as random color "checkerboard" pattern on screen
or no color.


Looks like the chip at U16 (MOS CD4066). Might not be but it kinda' sounds like what your picture looks like.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group