retrohackers.com
http://retrohackers.com/

Stupid Questions
http://retrohackers.com/viewtopic.php?f=15&t=357
Page 1 of 1

Author:  FMan [ Wed Mar 05, 2008 3:06 pm ]
Post subject:  Stupid Questions

This is the obligatory Stupid Questions thread. Please ask your simple (dumb) questions here, instead of starting a new topic for each little thing.

I'm gonna get it started: I have a C128 and C64 both equipped with RR-Net. How do I make them talk to each other? What programs are there for this?

Can we play Artillery Duel over LAN? Is there a possibility to transfer files/data between two C= computers? Anyone else with same setup who could give hints?

Author:  Schema [ Wed Mar 05, 2008 5:58 pm ]
Post subject: 

Artillery Duel works just fine on a LAN. Just make sure the computers have different IPs and MACs set in the config file. It doesn't support DHCP.

I'm not aware of a C64<->C64 Ethernet-based transfer utility yet.

Author:  RaveGuru [ Wed Mar 05, 2008 9:27 pm ]
Post subject: 

Ah yes, and some basic Networking hints: If you're not using a hub or switched hub (some times just called a 'switch') between your commies, you must use a crossed network cable. Use IP addresses in the 192.168.0.x range (netmask 255.255.255.0) to avoid trouble.

This brings up an interesting topic: What other software exist for interconnecting C64's (except Artillery Duel) ? Have anyone tried the 64 laned network solution, I don't remember the name currently. I think it was originally using the IEC bus but recently updated with RRnet support IIRC... What's the name? Gotta search the forum :P

Edit: Found it: http://retrohackers.com/forum/viewtopic.php?t=314

Seems very cool, although it uses a modded KERNEL.

What else is there?

Author:  hollowman [ Thu Mar 06, 2008 12:28 pm ]
Post subject: 

IIRC ,when Trident demoed contiki at lcp he tried to use one c64 as a webserver and surf to it from another c64, which didnt work at that time. A few years later and with a lot of changes I guess it should work to have two c64's using the clients and servers in contiki to communicate with eachother. Havent tried it though.

Author:  zap [ Thu Mar 06, 2008 3:13 pm ]
Post subject: 

I have a commodore 64 running as a web server. :shock:

Author:  FMan [ Mon Jul 14, 2008 5:06 am ]
Post subject:  Re: Stupid Questions

Thanks! I haven't gotten around to trying this out yet, but I've been fighting with 1541 Ultimate. I tested it using the card from my MMC Replay, but nothing is shown. The viewscreen is completely empty. :evil:

Doesn't it support FAT32 or is somehow specially prepared card needed? I also found out the reset button does not work when the browser is open. When I pressed the internal reset button of C128 the cart crashed. :roll:

The disk reader of MMC Replay seems to be broken: no file appears on the card. Have tested now several times with different cards. :? Also, trying to start MMC BIOS after being in the configuration menu will crash it.

Author:  mareLock [ Wed Mar 11, 2009 7:52 pm ]
Post subject:  Stupid Questions

hi i have a stupi questtion :P

is it posible to make a remote desktop app .... like contiki looks like but it controls my mac os x ??

or will that be to mutch ??

:)

with LoVe
marTeen

Author:  FMan [ Fri Mar 20, 2009 2:51 pm ]
Post subject:  Re: Stupid Questions

Everything is possible with enough resources thrown at the problem on hand. :lol: In practice I don't see anyone accepting that undertaking... A teletype terminal for BASIC is more feasible. ;)

Author:  RaveGuru [ Sun Mar 29, 2009 2:47 pm ]
Post subject:  Re: Stupid Questions

IIRC there's a VNC server in Contiki allowing you to remote control it, but I don't know if there's a client too.

Author:  FMan [ Sat Aug 15, 2009 10:17 am ]
Post subject:  Exomizer problem. Help!

Hello! I have finally started working on the RAM-version of a game I have wanted to do for many years. However, I almost immediately ran into a problem with exomizer. Some of the data I am packing with it fails to fully unpack. I have a data segment at $E000-$F10B, which stops unpacking at $E140. The problem seems to reside with the cruncher side, as the input data gets exhausted, ie. the depack pointer reaches the end of the crunched data - or rather the beginning, since it is read backwards. Someone mentioned a known bug in exomizer, but was unable to give any details, so is it something unrelated or am I suffering from it or what is happening and how can I fix this? :o

Author:  RaveGuru [ Mon Aug 17, 2009 1:33 pm ]
Post subject:  Re: Stupid Questions

FMan wrote:
Someone mentioned a known bug in exomizer, but was unable to give any details, so is it something unrelated or am I suffering from it or what is happening and how can I fix this? :o

Have you tried puCrunch ?

Author:  FMan [ Tue Aug 18, 2009 3:01 pm ]
Post subject:  Re: Stupid Questions

No. I prefer to try to find solutions and make things work rather than keep changing what I work with, but I guess I could check it out. It's just usually a huge effort to get something new to work and I am lazy. :)

Author:  RaveGuru [ Tue Aug 18, 2009 4:22 pm ]
Post subject:  Re: Stupid Questions

Come on! If even I can use puCrunch, it should be easy enough! :D
Seriously, I found it pretty convenient to work with.

Author:  mareLock [ Mon Sep 07, 2009 6:29 pm ]
Post subject:  Re: Stupid Questions

^^,

Page 1 of 1 All times are UTC + 1 hour [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/