It is currently Sat Apr 21, 2018 3:26 pm

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sun Mar 11, 2012 2:19 am 
Offline

Joined: Wed Mar 07, 2012 12:02 am
Posts: 1
Hi people
First of all, excuse me for my low english level, I'm still learning it, so it's going to be common find gramatical mistakes on my posts.

Well, let's start with my first post.

Recently I purchased a 64nic+ ethernet card for my c64. I just wanted to use it with my sd2iec from nkc electronics. (this one -> http://store.nkcelectronics.com/sd2iec-boar2.html )

First thing I tested was contiki. At first, with the ethernet card, there was included a 5 1/4 disk with contiki and some nice internet apps for use with the the 64nic+. Now the disk isn't included, but there is a .d64 file with all the files, downloadable from here -> ftp://n2dvm.com/Commodore/Programs/c64nic.d64 . I've tested it several times, and it doesn't works. The loading stops with this message: "starting config.prg", after finishing loading the desktop, and the red led from the sd2iec starts blinking. I load contiki with the load"contiki",8 command, because if I type load"*",8,1 nothing happens.

I also tested another "version" of contiki, with a custom config creator (here -> http://contiki.cbm8bit.com/) but the disks I get from there (after configure the network paramethers) doesn't include contiki, only some internet apps that, when I load them, doesn't seems to work. I always get the message "hostname not found". I also have tested the 3 versions for the 3 differents ethernet card: none of them include any contiki files.

Finally, today I wanted to test geos with geo link(this one -> http://lyonlabs.org/commodore/...k-1.01.d64) and now the problems are quite similar. I start it with the command load":*",8,1 (and also load"*",8,1, but, after a few seconds, there appears the next message: "please insert a disk with desktop 1.5 or higher" and, again, the red led of the sd2iec starts blinking.

The firmware installed on the sd2iec its the last one:0.10.3

Also, I've fully formated the sd card to see what happens, and nothing changed.

With this sd2iec card I'm able to load a lot of .d64 games, so it seems that it works.

Does anyone know what happens? maybe its an incompatibility issue.

thanks for your help.

Makinavaja


Top
 Profile  
Reply with quote  
PostPosted: Thu Apr 12, 2012 4:50 pm 
Offline
Site Admin

Joined: Wed Jan 11, 2006 12:22 pm
Posts: 860
Hi Makinavaja and welcome to the forum, sorry for late reply!

The problem you are experiencing is because Contiki, GEOS and many other programs (and games) use their own disk loaders, sometimes also known as "disk turbo" or "fast loader", etc. These "loaders" are actually small programs that execute inside the Commodore 1541 Diskdrive. The problem with sd2iec and other devices based on the 1541-III project is that they do not fully emulate a 1541 (which has its own processor, memory and kernel).

To run this kind of programs you need a device that fully emulates 1541, such as the 1541-Ultimate Cartridge, or even better: a REAL C=1541 Diskdrive :)


Top
 Profile  
Reply with quote  
PostPosted: Tue Apr 17, 2012 1:44 am 
Offline

Joined: Sun Feb 10, 2008 6:55 am
Posts: 75
uIEC runs the same firmware and there's a few folks on uIEC-users@googlegroups.com that have used it on GEOS and with Contiki. I'd recommend scanning the forum/mailing list and possible joining.

Jim


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group